อัพเกรด TYPO3 เป็นเวอร์ชั่นล่าสุด แล้ว HTML5 Syntax ทำงานไม่ถูกต้อง

แทบจะพลิกแผ่นดินแก้ไขตัว content rendering กับ feature HTML5 ที่ทำให้เราปวดกะบาลไม่น้อยเลยค่ะ ที่เวอร์ชั่นล่าสุดไม่รู้ทำกันอิท่าไหน HTML5 syntax ใหม่ ๆ ไม่ยอม register ใน system กันเลย

เอาหล่ะ!!! ใช้ เวอร์ชั่นที่เป็นแบบ long term ก็ได้ กับแพ็คเกจใหม่ ที่พึ่งจะ แง้ม solution ได้ไม่ทันจะ release ให้ได้เทสกัน เจ้ากรรมคนจ้องจะใช้ก็มีไม่น้อย สั่งทำเว็บไซต์ด้วยแพ็คเกจนี้ทันที

เศร้าสิค่ะพี่น้อง!!!! ก็เค้าอยากได้บน TYPO3 เวอร์ชั่นล่าสุด ทำยังไงหล่ะทีนี้ หยิบนู่น หยิบนี่ ใส่ใน Include static (from extensions) ก็ไม่เห็นมีไรเกิดขึ้น นั่งทำอยู่ 3 วัน เลยเศร้าใจ T_T ไม่ไหวแระ ต้องเคลียร์กับลูกค้าซะก่อน

HTML5 Syntax do not show after upgrade TYPO3 new version

แค่กำลังคิดจะคุยกับลูกค้า…. ดันคิดได้ว่าเราเคยมีเคสแบบนี้นิหน่า สด ๆ ร้อน ๆ ไม่กี่วันที่ผ่านมานิเอง -..-

หัวเราะเสียงดัง ๆ กับตัวเองแล้วก็เริ่มทดสอบทันที

เพื่อน ๆ เคยสังเกตกันไหมว่า….
เวอร์ชั่นใหม่ ๆ เวลาที่เรา Include static (from extensions) จะมองเห็นด้านขวามือ มี css_styled_content เวอร์ชั่นที่ต่ำกว่าอยู่ ก็ให้เลือกเวอร์ชั่นที่เราใช้พัฒนามาตั้งแต่แรก (ก็น่าจะไม่ต่ำกว่า TYPO3 v4.5) สำหรับการ upgrade เวอร์ชั่น TYPO3 เพียงเท่านี้ คุณก็ผ่านอุปสรรค์เกี่ยวกับ syntax HTML5 ที่ไม่ยอม register ในเวอร์ชั่นใหม่ ๆ แบบสบาย ๆ

Posted by:

Kickstarter
Administrator

5 Comments

  1. modv1 -  December 14, 2012 - 10:00 am

    TYPO3 6.0 ออกมาแล้ว ลองยัง มัน ok มั้ยครับ

    Reply
  2. modv1 -  December 19, 2012 - 2:39 pm

    แย่ละ รู้สึก 6.0 จะไม่ลองรับ automaketemplate
    ละ automaketemplate มันก็ไม่มีการอัพเดดเลยตั่งแต่ 2011
    ทำไงดี

    Reply
    • Kickstarter -  December 19, 2012 - 2:57 pm

      ใช้ FLUID + EXTBASE ค่ะ ^^

      Reply
  3. modv1 -  December 19, 2012 - 3:28 pm

    ตอนนี้ พออัพ 6.0 แล้ว tt_news มีปัญหาเลยครับ

    พออัพ tt_news เป็น 3.4.2 เท่านั้นล่ะ
    ล่มหมดเลย
    เข้าBackend (/typo3) ยังไม่ได้เลย ล่มหมด

    Reply
  4. modv1 -  December 19, 2012 - 4:21 pm

    updateๆ
    automaketemplate ยังใช้ได้ครับ แต่หน้าแรกผมมี tt_news
    เลยเข้าใจผิดคิดว่า automaketemplate ใช้ไม่ได้แล้ว จริงๆแล้วเป็นเพราะ tt_news ครับ

    แต่มีปัญหาใหม่
    โคด
    $TCA[“tt_content”][“columns”][“colPos”][“config”][“items”] = array (
    “3” => array (“CENTER||||||||||”,”3″),
    “2” => array (“RIGHT||||||||||”,”2″),
    “1” => array (“LEFT||||||||||”,”1″),
    “0” => array (“NORMAL||||||||||”,”0″),
    “4” => array (“BORDER2||||||||||”,”4″)
    );
    ที่เคยใส่ใน typo3conf/extTables.php ตอนนี้ใช้ไม่ได้ผลเลย กำลัง งง สุดๆ

    Reply

Leave A Comment

Your email address will not be published. Required fields are marked (required):

Human answer! *

Related articles

Back to Top