• TYPO3 อัพเดทเวอร์ชั่นจาก 4.5 ไป 6.2 และพบปัญหาใน Extension เดิม

    หลังจาก migration และทำการอัพเดท TYPO3 Core จากเวอร์ชั่น 4.5.x เป็นเวอร์ชั่น 6.2.1 แล้วพบปัญหาเกี่ยวกับการเรียกใช้งานของคลาส class.tslib_pibase.php ให้ตามบรรทัด Error นั้น ๆ ไปพบว่ามี require class ดังกล่าวไว้อยู่ ดังตัวอย่าง require_once(PATH_tslib . ‘class.tslib_pibase.php’); ให้แก้เป็น if (!class_exists(‘tslib_pibase’)) require_once(PATH_tslib . ‘class.tslib_pibase.php’); อาจจะไม่ใช่ทางแก้ที่ดีนัก แต่ถ้าอยากให้เว็บรันได้เร็วอีกครั้งก็ต้องใช้ แล้วค่อยหาวิธีแก้ในภายหลังคะ ชีวิตไม่สิ้นหวังนะคะ ขอให้มีความสุขกับการใช้งาน TYPO3 คะ ^_^

    Read more »

Back to Top